Mechanics

WHY WON'T MY SPARK?

1990 Ford Taurus • 250 miles

Ran out of gas, tried to restart many times- cranks but won't start, turned hazards on, returned filled gas- plenty, batt. Now dead, charged and jumped- wouldn't start (did I blow the EEC/PCM if I charged with key in the ON position- for the hazads?), Towed home. Checked fuel shut-off/ inertia switch- hadn't popped, removed fuel filter, primed fuel pump- 4-5 oz of gas came out, replaced filter, tested Schrader valve- seems to have sufficient psi, hmmmmm?
Checked spark- no spark and plugs wet (what happened?). Took the ignition control module to O'Reilly's- everything passed, rented OBD- no codes, looked up test for ignition coil and misread the test- bought a coil without need, bought plugs and wires, replaced all three, tried the test again-I get a light on my test light at the (+) wire to the coil and the (-) wire to the coil, however, when I crank the engine the test light does not flash as the test said it should when connected to the (-) wire of the ignition coil. So, I am told to check wiring from EEC to ign. Coil at the EEC looking for a constant light- couldn't identify wire and gave up on that. If the light had consant light the wire could be deemed ok and now the driver/transistor in the EEC would need to be looked into through examining the powers/ grounds to the EEC, but more probably the crankshaft position sensor and the camshaft position sensor and then the EEC itself.
This is where I am now. I want to test the two sensors and I want to know if I have properly narrowed the problem down to the sensors, EEC, and wires between them using the ignitiion coil test or if something else could be wrong like a problem in the distributor (PIP sensor?)
Avatar
Janesmith
August 13, 2012.



What engine? Check fuel pressure check fusible links at relay first. One may be burnt up like a blue one. Pic included.


Hmac300
Aug 13, 2012.
3.0L, engine cranks. I have no spark at plugs.


Tiny
Janesmith
Aug 13, 2012.
Check what I told you to in previous answer


Hmac300
Aug 13, 2012.
I had been tinkering w/ this thing all last week, then tried to get a mobile mech. To diagnose on weekend w/ no luck- I guess the weather is too nice or they r too busy. No I'm home and the car isn't, so I can't check now. Would improper fuel pressure or a bad fuel pressure regulator cause a no- spark condition? Also, any more details you could provide about the fusible links and wires in the attached diagram would be appreciated.


Tiny
Janesmith
Aug 13, 2012.
If you click on the pic it wil get larger for the diagram. These are right by the starter relay on the positive side of battery. You only need a stest light to check them. If it is bright on bat side and dim on other side of fusible link then the link is bad. Which the blue wires supply the ignition switch and power to SPARK. The wrong fuel pressure can cause your flooding condition on car. I would suggest taking plugs out to let them dryout from fuel.


Hmac300
Aug 13, 2012.
Also when I checked the psi it seemed to be around 35 (didn't have a pressure gauge after I had bled some air and fuel quite a few times, I got a good amount of fuel pressure each time I primed it.


Tiny
Janesmith
Aug 13, 2012.
35 should be ok.


Hmac300
Aug 13, 2012.
So, even if I have power at the + and - side of the coil, one of those links could be out? Are these wires fairly siple to locate and test?


Tiny
Janesmith
Aug 13, 2012.
If you have power at the coil you should have spark. Remove coil wire from dist and put close to ground, crank engine and if you have spark there, then it's eitehr a rotor or dist cap that is bad. If there is no spark from coil wire then try a new coil wire or in a pinch, cut a coat hanger and put from coil to dist. Try to start car if it starts you've found your problem.


Hmac300
Aug 13, 2012.
I have replaced the coil already, though I did do that test and later heard it could short the coil? Anyway, the coil did spark, so does this mean its the dist? Why didn't my test light flash on and of when attached to the - wire on the coil while cranking? Does that pulse come from the pulse generator in the dist? Thanks


Tiny
Janesmith
Aug 14, 2012.
Page 1 of 2