Mechanics

STARTING PROBLEMS(POSSIBLE BAD FUEL PUMP)

1987 Mercedes Benz 300e • 4 cylinder AWD Automatic • 102,000 miles

I have a 1987 Mercedes Benz 300E. I have had it for about 3 weeks. The car has been starting when it wants to. For example, in the beginning I would drive for about an hour and then cut the car off. When I would try to cut the car back on it would not start. It would make the noise as if it was going to start but then it wouldn't. After a few minutes of waiting and trying to start from time to time, then the car would start. As the problem persisted sometimes the car would start with no problem during driving trips with cutting the car off and on and then sometimes I would use starting fluid and spray it in what I believe is the "throttle" and then it would start. There was some stumbling and hesitation when accelerating but then when the fuel filter was changed that problem seemed to stop until about 2 days ago when I worked the graveyard shift and came back in the morning and started the car it started but there was some hesitation and stumbling when accelerating but after a couple minutes that stopped. Today I drove the car a few hours ago and cut it off and has not started since with several failed attempts and even after waiting a few hours and trying again. The latest so called mechanic told me that it was the fuel pump gone bad which made a little since the way he explained. However I'm just concerned because my starting problem was intermittent up until today when it seems that it just stopped starting st all. Please help me I a, at the end of my rope! Could it be the fuel pump, fuel pump relay, connections, or all? Please HELP!
Avatar
Jerrikajasper
February 22, 2011.



I have same problem with my Mercedes Benz 300e 1989 I just replece the Fuel Pump & it works now

Tiny
Ghost141184
Apr 24, 2011.