Mechanics

WHAT CAN I DO TO MAKE THIS CAR RUN????

1987 Chevrolet Cavalier • 65,587 miles

RS Convertible V6 2.8 MPFI Auto. Will start up rough Idle with foul exhaust (added seafoam) that can burn eyes but as soon as you put it under load (or) give it gas the roughness will go away at about 2-3000 rpm car lacks in Power and then will just die (bog) down.
Car sometimes will restart right away or you have to wait doesn't matter hot or cold.
Replaced Fuel Pump/bag filter, Fuel Filter, Fuel Lines, Mas, and yet no change with issue.
Then I have Cleaned the MAF, TPS, Still can not even pull out of (home) garage Any help would be greatly appreciated. Thanks in Advance.

Also car did sit (farm) in a garage for sometime so replaced gas and still same issue.
I did find a Spider (lol) Web in the TPS when I removed it and cleaned I have Metered With Analog tester and it tested good yet others still think TPS is problem. I am thinking the ECC/ECM or Fuel regulator but any more Money and wife will throw me out of house : (

One other note. When car was able to be driven on the road it just seemed to never have any "OOMPH" but as above now with the oomph it just won't stay running.
Thanks again from an "OLD" backyard Mechanic that loved Chevy before 1971
Avatar
Ragey
May 13, 2012.




First stop throwing parts at it. It sounds like a clogged cat. Unbolt the front pipe from the exhaust manifold and see if it runs better.

Roy

ASEMaster6371
May 13, 2012.
Hmm, You think it might (just) be the catalytic converter?
Son and I did use a hammer test and sounded solid, but then again your point is well taken.
Will let you know (fingers crossed) Thanks

Tiny
Ragey
May 13, 2012.
Good luck, get back to us

Roy

ASEMaster6371
May 13, 2012.
Hello Roy,
Sorry about not getting right back, but frustration set in and just needed to walk away, anyway. No change : (
Starts and idle the same except now fumes (*cough) are in FACE but as soon as you start to get at or above 2800 rpm it will bog down and die.
I did notice resistance on throttle ( using hand at ventura (cable from pedal) was like trying to twist back to an idle position. So I am unfortunate with it being so simple.
Thoughts are, maybe it is the TPS, as many continue with their thoughts (and mine) it seems, to be a process of elimination.
The more Brains the better or everyone has an opinion (OLD JOKE HERE) or like being in a line waiting to hear the word "NEXT" : )
By the way Roy I am Richard, Rageysdad is my gaming name as my son hooked me up with PC games and life has never been the same : )
AD

Tiny
Ragey
May 14, 2012.
Another little bit of info. I get no service engine soon or even any kind of code to show a problem. Though when I do jump the plug (OBD1) I will get the Flash once pause Flash Flash code = 12 Which show all systems good.
As I had mentioned above, We have tried and tested many different applications to no avail.
I am at a total loss (disability is hard enough) seems that it is time to invest money to local shop in area.
I do appreciate the suggestion of it being the "cat" but if anything was simple in life. We would not have had this conversation of sorts.
Thanks again
Richard

Tiny
Ragey
May 16, 2012.
AS I still have not resolved this issue, I am able to narrow it down to (as said 1st time) the ECM So for those of you that experience some of that which I have described (in extensive detail) I will let you know (at my expense) and update for FREE!

Tiny
Ragey
May 28, 2012.

AD