Mechanics

NO SPARK FROM SEC. COIL

1985 Pontiac Grand Am • 450,000 miles

I do not get spark from my coil to the dist.I do get feul to the tbi, but no gas comes from the injector. Not a drip.I've checked and replaced quite a few sensors. Ing. Components, distributor components, finally I purchased a new ecm, put my prom into it, now I have a trouble code of 51! My original did NOT have any codes. So I reinstalled my old one with the prom and now get 51 w/ my old one. Please help! Thank you.
Avatar
KyleT
September 30, 2013.



DTC - 51 prom error

Is the prom new? Did you check the ignition module?

No new prom. Did the prom mess up both my new and old ecu's? Also I did replace ing. Mod. So the only thing left to hopefully get back to square 1 is to get a new prom? I'm guessing if I do get my computer to no codes. AS long as I don't get any spark I won't see any gas trying to spray right? Went back to my manual again and looked to see what else to look for, and remembered that on the ecu box said to check all solenoids and looking thru the schematics I only found 1. It's for the fuel inj. Honestly even though it's on the schematic I can't find it. To me you have the connector to the fuel injector then it goes staight to the ecu.I know first things first to get the ecu right. Thanks hope you can still give me some more info.

Tiny
KyleT
Oct 1, 2013.
Sorry, but 1985 was a long time ago for me. I may be a bit rusty. Are you saying that there is no fuel either? Have you checked for an ASD? (Can't remember if this had one).

No ASD. I do get fuel all the way to the tbi. So I have fuel pressure. Also I just got back from the pick n pull and was lucky (maybe) enough to find an 86' stick shift same engine. So I grabbed the prom a little worried about it though.

Tiny
KyleT
Oct 2, 2013.
Let me know what happens.

I finally purchased a used ecm and now no codes. Now back to having no fuel or spark. I've gone thru most of the wiring end to end, so far no breaks or loose connections.

Tiny
KyleT
Feb 6, 2014.